summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:04:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 13:04:07 +0200
commitebcf956ec278ebb94e36a57dd5451a63543661f1 (patch)
tree20162a8de1b266cdaccbe19b4fbc01fd3d5e2d78
parent0d9557249e3ad1388f61ed11718bc87931414189 (diff)
gnu: Add texlive-pxjodel.
* gnu/packages/tex.scm (texlive-pxjodel): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3498d0ca9e..81753a265b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15176,6 +15176,29 @@ that authors can properly create PDF documents that contain document
information in Japanese.")
(license license:expat)))
+(define-public texlive-pxjodel
+ (package
+ (name "texlive-pxjodel")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pxjodel/"
+ "fonts/tfm/public/pxjodel/"
+ "fonts/vf/public/pxjodel/"
+ "tex/latex/pxjodel/")
+ (base32
+ "1g5sd60zd34ark50qy2dgqrdcd5pwy5hxmi6g5jxqlj3j1n6r1ny")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pxjodel")
+ (synopsis "Help change metrics of fonts from japanese-otf")
+ (description
+ "This package changes the setup of the @code{japanese-otf} package so
+that the TFMs for direct input are all replaced by new ones with prefixed
+names. This function will assist users who want to use the
+@code{japanese-otf} package together with tailored TFMs of Japanese fonts.")
+ (license license:expat)))
+
(define-public texlive-pwebmac
(package
(name "texlive-pwebmac")