summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-08-06 11:50:51 -0300
committerVinicius Monego <monego@posteo.net>2023-09-02 11:17:02 -0300
commitf3bbd0d26ff43c4b51d4b804655f7fe56d503427 (patch)
treeb3e14e090b2307bd9a7b460acfd249e7811b7550
parent4b4019789dc481509ce6dc5bdb97fed746a4b5cb (diff)
gnu: python-scrapy: Update to 2.10.1.
* gnu/packages/python-web.scm (python-scrapy): Update to 2.10.1. [build-system]: Use pyproject-build-system. [arguments]: Use G-Expressions. Do not override the check phase, skip tests in #:test-flags instead. Run tests sequentially and skip fewer tests.
-rw-r--r--gnu/packages/python-web.scm41
1 files changed, 17 insertions, 24 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2da3012173..93fd2d2278 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8065,36 +8065,29 @@ regular expressions.")
(define-public python-scrapy
(package
(name "python-scrapy")
- (version "2.7.1")
+ (version "2.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Scrapy" version))
(sha256
- (base32 "0kpi3hg2ycs6s8cg41r2zc1axd0rpnps8bnzg7wisjyjaf1l1yih"))))
- (build-system python-build-system)
+ (base32 "03yil4hjn14amx5jnvjfahmm78qqax2664z30xxn0dxmzdspimli"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest"
- "-n" (number->string (parallel-job-count))
- ;; These tests fail when run in parallel (see:
- ;; https://github.com/scrapy/scrapy/issues/5502).
- "--ignore" "tests/test_engine.py"
- "--ignore" "tests/test_engine_stop_download_bytes.py"
- "--ignore" "tests/test_engine_stop_download_headers.py"
- ;; This test require network access.
- "--ignore" "tests/test_command_check.py"
- "-k"
- (string-append
- ;; The followin tests fail for unknown reasons.
- "not test_server_set_cookie_domain_suffix_public_private"
- " and not test_user_set_cookie_domain_suffix_public_private"
- " and not test_pformat")
- "tests")))))))
+ (list #:test-flags
+ ;; Tests fail with DNS lookup or need a display.
+ #~(list "-k" (string-append
+ "not " (string-join
+ (list "test_SCRAPY_CHECK_set"
+ "test_check_all_default_contracts"
+ "test_check_cb_kwargs_contract"
+ "test_check_returns_items_contract"
+ "test_check_returns_requests_contract"
+ "test_check_scrapes_contract"
+ "test_pformat"
+ "test_pformat_old_windows"
+ "test_pformat_windows")
+ " and not ")))))
(propagated-inputs
(list python-botocore ; Optional: For S3FeedStorage class.
python-cryptography