summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-12 22:26:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:11 +0000
commit18ac6a247ca213d8ec52db3d6623ecf9120f6e20 (patch)
tree4b0bdf6b0e15663789254697fd11a9b75c94654d
parent36ce356616708084e2ad58cd328f5f6542e4a412 (diff)
gnu: Add python-ewah-bool-utils.
* gnu/packages/python-compression.scm (python-ewah-bool-utils): New variable. Change-Id: Ib9730d599f66bc2b864bfd305135e367f89ba9dd
-rw-r--r--gnu/packages/python-compression.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index d076a4e161..16e9fc7a4b 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -196,6 +196,41 @@ following algorithms are available:
@end itemize")
(license license:expat)))
+(define-public python-ewah-bool-utils
+ (package
+ (name "python-ewah-bool-utils")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ewah_bool_utils" version))
+ (sha256
+ (base32 "11z9vv9m19370j762z100dqhy2ndjzkxk3w9z02lzwadbyibal3h"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-cython python-pytest))
+ (propagated-inputs
+ (list python-numpy))
+ (home-page "https://github.com/yt-project/ewah_bool_utils")
+ (synopsis "EWAH Bool Array compression")
+ (description "This package provide a Python wrapper to @acronym{EWAH,
+ Enhanced Word-Aligned Hybrid} compression bitarray method.")
+ (license (list
+ ;; LICENSE: for Python code.
+ license:bsd-3
+ ;; XXX: Check if it's possible to have it as a dedicated package
+ ;; and link here..
+ ;; ewah_bool_utils/cpp/LICENSE: for C++ bundle, sourced from
+ ;; <https://github.com/lemire/EWAHBoolArray>.
+ license:asl2.0))))
+
(define-public python-pybcj
(package
(name "python-pybcj")