summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-05 23:06:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:07 +0000
commit1a3aa6b19bd82db3890f8eb2170093fedcb96c88 (patch)
tree96c35815ee1ae18e2553508ed9d92c601016f180
parentbb1e74a96fe6ae68e4cec8cc5aec3a4e7ea70133 (diff)
gnu: python-zarr: Speed up tests.
* gnu/packages/python-xyz.scm (python-zarr): Use G-expressions. [arguments] <#:test-flags>: Parallelize tests to speed them up. <#:phases>: 'disable-service-tests remove trailing #t from lambda. Use standard 'check phase. [native-inputs]: Add python-fsspec, python-h5py, python-pytest-doctestplus, python-pytest-timeout, and python-pytest-xdist. Change-Id: I3fc4e2a1649ad9f95ed9e3fe87e3f57ad4f58af8
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dbb6a8b89e..2dfffe15df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27134,23 +27134,29 @@ codecs for use in data storage and communication applications.")
"0qb2wj60i7v1c95k6m0pskx20ss6dxrj3ym0d7z4c98jfah3ljsn"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-service-tests
- (lambda _
- (setenv "ZARR_TEST_ABS" "0")
- (setenv "ZARR_TEST_MONGO" "0")
- (setenv "ZARR_TEST_REDIS" "0")
- #t))
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv" "-k" "not lmdb")
- #t)))))
+ (list
+ #:test-flags
+ #~(list "-n" "auto")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-service-tests
+ (lambda _
+ (setenv "ZARR_TEST_ABS" "0")
+ (setenv "ZARR_TEST_MONGO" "0")
+ (setenv "ZARR_TEST_REDIS" "0"))))))
(propagated-inputs
- (list python-asciitree python-fasteners python-numcodecs
+ (list python-asciitree
+ python-fasteners
+ python-numcodecs
python-numpy))
(native-inputs
- (list python-pytest python-setuptools-scm))
+ (list python-fsspec
+ python-pytest
+ python-h5py
+ python-pytest-doctestplus
+ python-pytest-timeout
+ python-pytest-xdist
+ python-setuptools-scm))
(home-page "https://github.com/zarr-developers/zarr-python")
(synopsis "Chunked, compressed, N-dimensional arrays for Python")
(description