summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-11 14:13:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:07 +0000
commit249f0a9c9fa5e663150b58be9846e6ca49b59214 (patch)
tree633c6773cff2f5bf10a525ced5068cc9fb8b26be
parent1a3aa6b19bd82db3890f8eb2170093fedcb96c88 (diff)
gnu: python-distributed: Speed up tests.
* gnu/packages/python-science.scm (python-distributed) [arguments] <#:test-flags>: Add option to run tests in parallel. Disable 3 more flaky tests. [native-inputs]: Add python-pytest-xdist. Sort alphabetically. Change-Id: I588c1a1dc82e3208cc1eeeefbdc58fb080775ac0
-rw-r--r--gnu/packages/python-science.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b00dd9455d..a4724598b7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1672,7 +1673,8 @@ Mathematics (GLM) library to Python.")
(arguments
(list
#:test-flags
- '(list "-x" "-m"
+ '(list "-n" "auto"
+ "-x" "-m"
(string-append "not slow"
" and not flaky"
" and not gpu"
@@ -1798,7 +1800,10 @@ Mathematics (GLM) library to Python.")
;; These tests are rather flaky
" and not test_quiet_quit_when_cluster_leaves"
" and not multiple_clients_restart"
- " and not test_steal_twice"))
+ " and not test_steal_twice"
+ " and not test_task_groups_update_start_stop"
+ " and not test_web_preload"
+ " and not test_web_preload_worker"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'versioneer
@@ -1873,10 +1878,11 @@ parentdir_prefix = distributed-
python-urllib3
python-zict))
(native-inputs
- (list python-importlib-metadata
+ (list python-flaky
+ python-importlib-metadata
python-pytest
python-pytest-timeout
- python-flaky
+ python-pytest-xdist
python-versioneer))
(home-page "https://distributed.dask.org")
(synopsis "Distributed scheduler for Dask")