summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-09 21:37:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:09 +0000
commit250f181744f7ff641130eff2b0b8f9850e2e449c (patch)
treece224a6fd077230e364d84b874c70f0079ff3c4d
parentdc21d8e57ab873ef7a465dd93dcc0f8a44ff1896 (diff)
gnu: python-asdf: Update to 3.1.0.
* gnu/packages/astronomy.scm (python-asdf): Update to 3.1.0. [arguments] <#:phases>: Add 'fix-test-setup phase. <#:test-arguments>: Move "-p no:legacypath" option from pyproject.toml to here. Change-Id: Ief5734d97d483d2e7af3ea59d702fd4697eb048a
-rw-r--r--gnu/packages/astronomy.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ff45ca1434..57585619dc 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4254,18 +4254,26 @@ between image and reference catalogs. Currently only aligning images with
(define-public python-asdf
(package
(name "python-asdf")
- (version "3.0.1")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf" version))
(sha256
- (base32 "1jsk7b4mx04l0a08j832vnl309dba3gjnha9mbd61dzs9ridrfna"))))
+ (base32 "0fa6y3gmqc0y3nz0h68vq3a84pvx6gc5zp33wg8a4n9b4kipm464"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list "-n" "auto")))
+ #~(list "-n" "auto" "-p" "no:legacypath")
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; ImportError: Error importing plugin " no:legacypath": No module
+ ;; named ' no:legacypath'
+ (add-before 'check 'fix-tests-setup
+ (lambda _
+ (substitute* "pyproject.toml"
+ ((".*:legacypath.*") "")))))))
(native-inputs
(list python-fsspec
python-packaging