summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 19:00:37 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 19:08:08 +0000
commit25d66b55c23b6aed19e777289b638c327b732c8e (patch)
treed227e999db7ce894c1924f7af4cf1153da3e8c5b
parent6cde0f480dca28426a5634b70dd963d2de7bcf36 (diff)
gnu: python-distributed: Disable parallel tests.
As seen in <https://ci.guix.gnu.org/build/3708961/log/raw>, parallel tests introduced package build regression. * gnu/packages/python-science.scm (python-distributed) [arguments] <#:test-flags>: Disable parallel tests. [native-inputs]: Remove python-pytest-xdist. Change-Id: I3a04098604fa03ab91ceb228dd70c34c3d84db78
-rw-r--r--gnu/packages/python-science.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index a4724598b7..93d3b25272 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1673,8 +1673,7 @@ Mathematics (GLM) library to Python.")
(arguments
(list
#:test-flags
- '(list "-n" "auto"
- "-x" "-m"
+ '(list "-x" "-m"
(string-append "not slow"
" and not flaky"
" and not gpu"
@@ -1882,7 +1881,6 @@ parentdir_prefix = distributed-
python-importlib-metadata
python-pytest
python-pytest-timeout
- python-pytest-xdist
python-versioneer))
(home-page "https://distributed.dask.org")
(synopsis "Distributed scheduler for Dask")