summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-11 21:03:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:10 +0000
commit278bc81add37856f7fc26168ab5adb867d089672 (patch)
treed2d25be1c56262e639ac7f4c22e60a46340e4711
parent5828d493597ee25554013809f4314e1429c2dec0 (diff)
gnu: python-stcal: Enable sanity check.
* gnu/packages/astronomy.scm (python-stcal) [arguments] <#:phases>: Revert 'sanity-check phase. Add 'silent-check-for-opencv phase. Change-Id: Ifd3ae01d261fe6dba8f5e75d4a5134510d826a57
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 431bd0346e..4d1bbcec87 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3140,9 +3140,12 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: Can't detect opencv-python version. The input opencv might
- ;; not set the version correctly.
- (delete 'sanity-check)
+ (add-before 'build 'silent-check-for-opencv
+ (lambda _
+ ;; XXX: Can't detect opencv-python version. The input opencv
+ ;; might not set the version correctly.
+ (substitute* "pyproject.toml"
+ ((".*opencv-python-headless.*") ""))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.