summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-12 18:47:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:08 +0000
commit2962c0f0259826c7782503a0633a571d81b89527 (patch)
tree3186c1c1d3018d881e2fd7fff4d6d5d0eac3b964
parent9b0508e204e4857c9ff35258cc2598ba3a33f782 (diff)
gnu: python-stdatamodels: Speed up tests.
gnu/packages/astronomy.scm (python-stdatamodels): Enable parallel tests to speed them up. [arguments] <#:test-flags>: Add "-n" option. [native-inputs]: Add python-pytest-xdist. Change-Id: I43390240a4a0db48d9abab4c34d1c1c771028486
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 724643d17f..4b3ebd642e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3181,9 +3181,11 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(build-system pyproject-build-system)
(arguments
(list
- ;; Disable tests requiring access to CRDS servers to download ~500MiB of
- ;; data.
- #:test-flags #~(list "-k" "not test_crds_selectors_vs_datamodel")
+ #:test-flags
+ #~(list "-n" "auto"
+ ;; Disable tests requiring access to CRDS servers to download
+ ;; ~500MiB of data.
+ "-k" "not test_crds_selectors_vs_datamodel")
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'set-home
@@ -3199,6 +3201,7 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(list python-crds
python-pytest
python-pytest-doctestplus
+ python-pytest-xdist
python-scipy
python-semantic-version
python-setuptools-scm))