summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-11 18:41:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:08 +0000
commit2de864d20483c7f5a6f0a85dbec05e96b3d78720 (patch)
tree460b562dca880ab05dbf5e56963d8bcd00da8511
parent2962c0f0259826c7782503a0633a571d81b89527 (diff)
gnu: python-glymur: Speed up tests.
* gnu/packages/python-xyz.scm (python-glymur): Enable parallel tests to speed them up. [arguments] <#:test-flags>: Add it with "-n" option. [native-inputs]: Add python-pytest-xdist. Change-Id: Ied066330cc24a50b47307cefb2694675be8af0a4
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a7e85bcf9..11ea20aefb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1958,6 +1958,8 @@ Python library and command line interface.")
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ #~(list "-n" "auto")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-library-locations
@@ -1983,7 +1985,9 @@ Python library and command line interface.")
;; which is patched above.
(delete-file "tests/test_config.py"))))))
(native-inputs
- (list python-pytest python-scikit-image))
+ (list python-pytest
+ python-pytest-xdist
+ python-scikit-image))
(inputs
(list openjpeg ; glymur/lib/openjp2.py
libtiff)) ; glymur/lib/tiff.py