summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-05 22:36:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:07 +0000
commit2f3a26eedf47449f7d4733b230f1bafc36e6b75b (patch)
treefd792fac145fca8ff4ce9dc63c8712fcd11cc0c8
parent06dd8b310fc86f4a15e86e0572fc6734c524df55 (diff)
gnu: python-pytest-arraydiff: Enable tests.
* gnu/packages/python-check.scm (python-pytest-arraydiff): Enable tests. [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Disable tests requiring python-astropy to break dependencies cycle. Change-Id: I0e4b6681d106a999c6fc12c3fd8c8f084762a92e
-rw-r--r--gnu/packages/python-check.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b389c3247f..551b67d81c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -553,13 +553,18 @@ astropy related packages.")
(uri (pypi-uri "pytest-arraydiff" version))
(sha256
(base32 "1pk7v96rkypx4ld59f6p8fh5bq371ka8g7bh4h7n4df91x2v2dr9"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- ;; Tests require python-astropy, which itself requires this package.
- ;; Disable tests to avoid the circular dependency problem.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ #~(list "-k" (string-append
+ ;; Disable tests requiring python-astropy, to break cycle.
+ "not test_succeeds_func_fits_hdu"
+ " and not test_fails"
+ " and not test_generate"
+ " and not test_default_format"))))
(native-inputs
- (list python-pytest python-setuptools-scm)) ; for sanity-check
+ (list python-pytest python-setuptools-scm))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/astropy/pytest-arraydiff")