summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-12 22:13:40 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:11 +0000
commit36ce356616708084e2ad58cd328f5f6542e4a412 (patch)
tree9b4be122109ddde5cda2ccf1aeba540ea4d87b5c
parent632cb6aa551c74ce7d936af77f891c9fef59525e (diff)
gnu: Add python-nose-exclude.
* gnu/packages/check.scm (python-nose-exclude): New variable. Change-Id: I5c91b682163890c822f7d4a548e92fdd287d78a2
-rw-r--r--gnu/packages/check.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7fd28c3ac7..d0fd975487 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
-;;; Copyright © 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2022-2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
@@ -2963,6 +2963,37 @@ JSON APIs with Behave.")
@command{nosetests} command of the Python Nose unit test framework.")
(license license:bsd-3)))
+(define-public python-nose-exclude
+ (package
+ (name "python-nose-exclude")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nose-exclude" version))
+ (sha256
+ (base32 "0123x1lyv5b2p9civcfg8vilj2ga3q7p2ks1hq25z0gb3ssai3zp"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-test
+ (lambda _
+ ;; Disable failing test: AssertionError.
+ (substitute* '("test_dirs/build/test.py"
+ "test_dirs/test_not_me/test.py")
+ (("def test_i_should_never_run")
+ "def off_i_should_never_run")))))))
+ (propagated-inputs
+ (list python-nose))
+ (home-page "https://github.com/kgrandis/nose-exclude")
+ (synopsis "Exclude specific directories from nosetests runs")
+ (description
+ "@code{nose-exclude} is a Nose plugin that allows you to easily specify
+directories to be excluded from testing.")
+ (license license:lgpl2.1+)))
+
(define-public python-nose-random
(package
(name "python-nose-random")