summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-11 14:32:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:10 +0000
commit427c271aea25a90025c3ef7248f849549ecd9358 (patch)
treed158e02f9e452f0f4fa58643846aab3058f81e05
parent00dcf62a8d98e748d917219e4a8d816bff24cfbf (diff)
gnu: python-suntime: Refresh package style.
* gnu/packages/astronomy.scm (python-suntime): Re-indent package. [build-system]: Swap to pyproject-build-system [description]: Concatenate small paragraphs into single one. Change-Id: I368f042eeab2f49c6f41b2ccf0c9a69c8abfec17
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index db220857f5..2986079221 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4156,21 +4156,21 @@ spectra, and data.")
(package
(name "python-suntime")
(version "1.3.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "suntime" version))
- (sha256
- (base32
- "1kyd1r6zcs0jmh5gq74adrnb1h7dfr1mzjq4k4vbngfiga8gfd28"))))
- (build-system python-build-system)
- (propagated-inputs (list python-dateutil))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "suntime" version))
+ (sha256
+ (base32 "1kyd1r6zcs0jmh5gq74adrnb1h7dfr1mzjq4k4vbngfiga8gfd28"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-dateutil))
(home-page "https://github.com/SatAgro/suntime")
(synopsis "Sunset and sunrise time calculation python library")
(description
- "Python library doing sunrise and sunset time calculation.
-
-Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
-datetime object.")
+ "Python library doing sunrise and sunset time calculation. Takes a
+WGS84 (GPS) latitude/longitude as input as well as an UTC or local datetime
+object.")
(license license:lgpl3+)))
(define-public python-synphot