summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2024-03-29 11:38:10 -0500
committerjgart <jgart@dismail.de>2024-03-29 12:04:32 -0500
commit6cde0f480dca28426a5634b70dd963d2de7bcf36 (patch)
treed3277fd2d0e0b8d08224c866aef1730209960e59
parent37d31495c1c3c38d1b74e0c5b3ba279c1d99c7d5 (diff)
gnu: Add python-apprise.
* gnu/packages/python-xyz.scm (python-apprise): New variable. Change-Id: I55b8c7b558ce34835cff31b9fac6ff3b81ff5fec Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5eb5cd958b..c0a432b52b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -231,6 +231,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -293,6 +294,51 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-apprise
+ (package
+ (name "python-apprise")
+ (version "1.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apprise" version))
+ (sha256
+ (base32 "0wvs1k71fipn617y9wsdcvwcgg2pd0nvriarlwl4438la4086ppg"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-certifi
+ python-click
+ python-dataclasses
+ python-markdown
+ python-pyyaml
+ python-requests
+ python-requests-oauthlib))
+ (native-inputs (list python-babel
+ python-coverage
+ python-cryptography
+ python-flake8
+ python-paho-mqtt
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-pytest-xdist
+ python-wheel))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (delete-file "test/test_plugin_macosx.py")
+ (invoke "pytest")))))))
+ (home-page "https://github.com/caronc/apprise")
+ (synopsis
+ "Push notification Python library that works with many platforms")
+ (description
+ "Apprise is a Python library that allows sending push notifications to a broad
+range of notification services, such as Telegram, Discord, Slack, Amazon SNS,
+Gotify, etc.")
+ (license license:bsd-2)))
+
(define-public python-xmldiff
(package
(name "python-xmldiff")