summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-23 19:39:30 -0300
committerVinicius Monego <monego@posteo.net>2024-03-29 16:19:51 -0300
commit905a3061020eee1bd70bbb16f705e845fa93b0a8 (patch)
treeaf612eb0a9c5ff9e18981080bb7ce52ab1b68bee
parenta65a96aff6e90af97e9551a7b044d7e3da6f2c1e (diff)
gnu: python-kombu: Update to 5.3.6.
* gnu/packages/python-xyz.scm (python-kombu): Update to 5.3.6. [build-system]: Use pyproject-build-system. [arguments]: Do not override the check phase. Ignore a file in #:test-flags. [native-inputs]: Add python-botocore, python-tzdata. Remove python-pytz. [propagated-inputs]: Add python-typing-extensions. Remove python-cached-property. Change-Id: I4b36effff8b17af388d56c90bf8983954adf4333
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 45f3c91adb..ef23359fa7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19048,30 +19048,27 @@ applications.")
(define-public python-kombu
(package
(name "python-kombu")
- (version "5.2.4")
+ (version "5.3.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "kombu" version))
(sha256
- (base32 "044ng79gj04668kf5fmy7fjkw8302xyapskkn65ym52zfbpf7kip"))))
- (build-system python-build-system)
+ (base32 "1n9i4hj1h3aivgy82l7accyjh1rqn20am00152l5syhl19bmpnpk"))))
+ (build-system pyproject-build-system)
(arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- ;; The transport tests attempt to pass messages to
- ;; many different databases.
- "--ignore" "t/unit/transport")))))))
+ (list #:test-flags
+ ;; TODO: Package azure-identity (required for this file)
+ #~(list "--ignore" "t/unit/transport/test_azurestoragequeues.py")))
(native-inputs
- (list python-case python-pyro4 python-pytest-sugar
- python-pytest python-pytz))
+ (list python-botocore
+ python-case
+ python-pyro4
+ python-pytest
+ python-pytest-sugar
+ python-tzdata))
(propagated-inputs
- (list python-amqp python-cached-property python-vine))
+ (list python-amqp python-typing-extensions python-vine))
(home-page "https://kombu.readthedocs.io")
(synopsis "Message passing library for Python")
(description "The aim of Kombu is to make messaging in Python as easy as