summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-10 14:27:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:09 +0000
commit988c730a9a2b8ca836b9aa24db996c6a1f1e2a10 (patch)
tree1d8f7f67604674abeeb5f95835d3b1e375046b89
parentf730baee59722fdd8438fe444aed87d77c88c973 (diff)
gnu: python-astroquery: Update to 0.4.7.
* gnu/packages/astronomy.scm (python-astroquery): Update to 0.4.7. [arguments] <#:test-flags>: Disable one failing test. <#:phases>: Remove 'prepare-test-environment phase. Add custom 'check phase. Change-Id: I159a9d765de7f8de00c4bf226febfc90d2ba6c76
-rw-r--r--gnu/packages/astronomy.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b3ce51c8df..efd70f5500 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1739,34 +1739,37 @@ celestial-to-terrestrial coordinate transformations.")
(define-public python-astroquery
(package
(name "python-astroquery")
- (version "0.4.6")
+ (version "0.4.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astroquery" version))
(sha256
- (base32 "1vhkzsqlgn3ji5by2rdf2gwklhbyzvpzb1iglalhqjkkrdaaaz1h"))))
+ (base32 "1jbyfhqk74wsdjxzqi0hcrgc7ha4q8cyjx96nv6w9bjg1b5vlzq4"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
#~(list "--pyargs" "astroquery"
- "-m" "not remote_data")
+ "-m" "not remote_data"
+ ;; Some tests failed with parallel run, see
+ ;; <https://github.com/astropy/astroquery/issues/2968>.
+ ;; "-n" "auto"
+ "-k" (string-append
+ ;; Failed: DID NOT RAISE <class
+ ;; 'astropy.utils.exceptions.AstropyDeprecationWarning'>
+ "not test_raises_deprecation_warning"))
#:phases
#~(modify-phases %standard-phases
- (add-before 'check 'prepare-test-environment
- (lambda _
- (setenv "HOME" (getcwd)) ; some tests need a writable home
- ;; To solve pytest/conftest issue. Pytest tries to load all
- ;; files with word 'test' in them.
- ;;
- ;; ImportError while loading conftest ...
- ;; _pytest.pathlib.ImportPathMismatchError: ...
- ;;
- (call-with-output-file "pytest.ini"
- (lambda (port)
- (format port "[pytest]
-python_files = test_*.py"))))))))
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ ;; Some tests require write access to $HOME.
+ (setenv "HOME" "/tmp")
+ ;; Step out of the source directory to avoid interference;
+ ;; we want to run the installed code with extensions etc.
+ (with-directory-excursion "/tmp"
+ (apply invoke "pytest" "-v" test-flags))))))))
(propagated-inputs
(list python-astropy
python-beautifulsoup4