summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-10 09:26:46 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:07 +0000
commit9b0508e204e4857c9ff35258cc2598ba3a33f782 (patch)
tree21e004effe268301778cf56b4d4737b26488d41d
parent249f0a9c9fa5e663150b58be9846e6ca49b59214 (diff)
gnu: python-dask: Speed up tests.
* gnu/packages/python-xyz.scm (python-dask) [arguments] <#:test-flags>: Add option to run tests in parallel. [native-inputs]: Add python-xdist. Reformat as a list. Change-Id: I9b4b1c53f827e1f5d3edd0908f8e37e1a3bddb71
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dfffe15df..3a7e85bcf9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27643,7 +27643,8 @@ decisions with any given backend.")
(list
;; Avoid coverage
#:test-flags
- #~(list "-m" "not gpu and not slow and not network"
+ #~(list "-n" "auto"
+ "-m" "not gpu and not slow and not network"
"-k" (string-append
;; This one cannot be interrupted.
"not test_interrupt"
@@ -27696,7 +27697,10 @@ parentdir_prefix = dask-
python-pyyaml))
(native-inputs
(list python-importlib-metadata
- python-pytest python-pytest-runner python-pytest-rerunfailures
+ python-pytest
+ python-pytest-rerunfailures
+ python-pytest-runner
+ python-pytest-xdist
python-versioneer))
(home-page "https://github.com/dask/dask/")
(synopsis "Parallel computing with task scheduling")