summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-18 14:46:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:12 +0000
commitb0b9d757a73f0c7495537f82b33372cf5a2c1517 (patch)
tree6dbb132a5fe586c0fa8be5b5761c9c5ace9fc987
parenta0cf3af1ad75d33b52c9557c3b1cf34ffe54838b (diff)
gnu: python-hvpy: Update to 1.1.0.
* gnu/packages/astronomy.scm (python-hvpy): Update to 1.1.0. [propagated-inputs]: Remove python-pydantic; add python-pydantic-2 and python-pydantic-settings. Change-Id: Id567cff01204d2e8d71bc49ec9ffc88b2bbb3f4e
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 14b2c37343..bde29f7990 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2305,18 +2305,20 @@ exitinction laws found in the literature.")
(define-public python-hvpy
(package
(name "python-hvpy")
- (version "1.0.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hvpy" version))
(sha256
- (base32 "0r0asyflz2sw9zn5vgs138nh81m0rbwbakmrncbc1ghdr3g6jahv"))))
+ (base32 "0bly1bgp0axxhzzf5imqsgmms41z8cxbjahxsibvb55dk94gwig6"))))
(build-system pyproject-build-system)
(arguments
(list #:tests? #f)) ; Requires HTTP(S) access to api.beta.helioviewer.org
- (propagated-inputs (list python-pydantic python-requests))
- (native-inputs (list python-pytest python-pytest-astropy))
+ (propagated-inputs
+ (list python-pydantic-2 python-pydantic-settings python-requests))
+ (native-inputs
+ (list python-pytest python-pytest-astropy))
(home-page "https://helioviewer.org/")
(synopsis "Helioviewer Python API Wrapper")
(description "@code{hvpy} is a Python API wrapper around the formal