summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:27:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commit206195d4e24628739871b837d9986fb827c20086 (patch)
treeea8ab12855a9560b174f9bfacc8e1c2a45eed9cd
parenteb4b61c7b2c2d4c8a54a6f30cd7abafe0d4d70ff (diff)
gnu: Add r-filesstrings.
* gnu/packages/cran.scm (r-filesstrings): New variable.
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5d67cdff5c..52d109ca93 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24858,6 +24858,38 @@ been tested on multi-terabyte matrices. It allows for more than 2^32 rows or
columns, ad allows for quick addition of extra columns to a filematrix.")
(license license:lgpl3)))
+(define-public r-filesstrings
+ (package
+ (name "r-filesstrings")
+ (version "3.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "filesstrings" version))
+ (sha256
+ (base32
+ "1jl3jhkdjx5x00kllnkpvrlpsmzsvlgd6vhzdavd39zx4jzwjxw3"))))
+ (properties `((upstream-name . "filesstrings")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-magrittr
+ r-purrr
+ r-rlang
+ r-strex
+ r-stringi
+ r-stringr
+ r-withr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/rorynolan/filesstrings")
+ (synopsis "Handy file and string manipulation")
+ (description
+ "This started out as a package for file and string manipulation. Since
+then, the @code{fs} and @code{strex} packages emerged, offering functionality
+previously given by this package. Those packages have hence almost pushed
+filesstrings into extinction. However, it still has a small number of unique,
+handy file manipulation functions which can be seen in the vignette. One
+example is a function to remove spaces from all file names in a directory.")
+ (license license:gpl3)))
+
(define-public r-acmeeqtl
(package
(name "r-acmeeqtl")