summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:31:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commit48e5c3bd290da7e796197f972645ae7a19a5677c (patch)
tree170e805231c151ec323b536b61bb9fd0eed02579
parent971778f20b3ce5a5836ed43e238ea43b67909050 (diff)
gnu: Add r-lamw.
* gnu/packages/cran.scm (r-lamw): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3eb1d1dc42..174c85a964 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5576,6 +5576,27 @@ selection, as well as methods for retrieving coordinates, for subsetting,
print, summary, etc.")
(license license:gpl2+)))
+(define-public r-lamw
+ (package
+ (name "r-lamw")
+ (version "2.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "lamW" version))
+ (sha256
+ (base32
+ "05b37kx4jpszx2hkm47d7cjkf8544f7r8x26q68yp9c6zqm9gbc3"))))
+ (properties `((upstream-name . "lamW")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcppparallel))
+ (home-page "https://github.com/aadler/lamW")
+ (synopsis "Lambert-W function")
+ (description
+ "This package implements both real-valued branches of the Lambert-W
+function (Corless et al, 1996) <doi:10.1007/BF02124750> without the need for
+installing the entire GSL.")
+ (license license:bsd-2)))
+
(define-public r-laplacesdemon
(package
(name "r-laplacesdemon")