summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-19 09:14:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-19 10:35:45 -0500
commit636b771536b95d15a2fd68b468deeebac97d6bee (patch)
tree34c9419a4aa0584a5f71e16047b9ecdb81bd8db7
parent57495d063587e9301feddbe051abe2f97ca038be (diff)
gnu: hplip-next: Simplify the fix-more-hard-coded-file-names phase.
* gnu/packages/cups.scm (hplip-next) [phases]: Only substitute python files in the fix-more-hard-coded-file-names phase. This greatly reduce the time taken by the phase (from 21 s to 0.4 s) on my system, and is functionally equivalent.
-rw-r--r--gnu/packages/cups.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index f1007ea03b..08677d612a 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -715,13 +715,10 @@ should only be used as part of the Guix cups-pk-helper service.")
#~(modify-phases #$phases
(add-after 'unpack 'fix-more-hard-coded-file-names
(lambda* (#:key outputs #:allow-other-keys)
- ;; Set the encoding to ISO-8859-1, as not all the files are
- ;; readable as UTF-8.
- (with-fluids ((%default-port-encoding "ISO-8859-1"))
- (substitute* (find-files ".")
- (("/etc/hp/hplip.conf")
- (string-append (assoc-ref outputs "out")
- "/etc/hp/hplip.conf"))))))))))))
+ (substitute* (find-files "." "\\.py$")
+ (("/etc/hp/hplip.conf")
+ (string-append (assoc-ref outputs "out")
+ "/etc/hp/hplip.conf")))))))))))
(define-public hplip-minimal
(package/inherit hplip