summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-13 10:20:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-19 20:03:34 -0500
commit6375e2e39c74b3cc702917314f93de7315bec918 (patch)
treef09f1f50781adf12cdb638669e84d5275b38a972
parentefd9f326aec7ef791e8ca9f1b37e194ec175f19d (diff)
gnu: icedove: Automatically load system-provided extensions.
* gnu/packages/gnuzilla.scm (icedove-source): Set the extensions.autoDisableScopes preference value to 3. (icedove-minimal) [phases]: Add the --allow-addon-sideload and --with-unsigned-addon-scopes=app,system ac options to the configure phase.
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 4e1260f851..babf97e65c 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1273,7 +1273,15 @@ list of languages supported as well as the currently used changeset."
(("(pref\\(\"extensions.systemAddon.update.enabled\").*" _ m)
(string-append m ", false);"))
(("(pref\\(\"lightweightThemes.update.enabled\").*" _ m)
- (string-append m ", false);")))
+ (string-append m ", false);"))
+
+ ;; XXX: The autoDisableScopes is tweaked by the makeicecat
+ ;; script, but it doesn't know about Thunderbird. This is
+ ;; necessary to allow picking up the extensions found in the
+ ;; system global application directory, such as the language
+ ;; packs.
+ (("\"extensions.autoDisableScopes\", 15")
+ "\"extensions.autoDisableScopes\", 3"))
;; Step out of the directory and create the tarball.
(chdir "..")
@@ -1386,6 +1394,8 @@ ca495991b7852b855"))
(lambda ()
(display
(string-append
+ "ac_add_options --allow-addon-sideload\n"
+ "ac_add_options --with-unsigned-addon-scopes=app,system\n"
"ac_add_options --disable-crashreporter\n"
"ac_add_options --disable-debug\n"
"ac_add_options --disable-debug-symbols\n"