summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2023-02-12 09:02:45 +0000
committerJulien Lepiller <julien@lepiller.eu>2023-02-19 10:09:16 +0100
commit819aaca9d524d2fde3ed82c688d3731ca1797f87 (patch)
tree1fd3b75f30755a5854c3aeb609cc9ca7ab77654f
parent189525412e3d803f3f77e15ec4a62aaa57f65a2d (diff)
gnu: php: Drop a failed test for riscv64.
* gnu/packages/php (php): Drop a failed test for riscv64. [source, arguments, description]: Fix formatting.
-rw-r--r--gnu/packages/php.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index e0cd47b846..c2539ef7fc 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -71,7 +71,7 @@
(base32
"0czflx9ikxymjfgnzaifjx9kc30ww2x4063075hcifjjwqwami5x"))
(patches
- (search-patches "php-fix-streams-copy-length.patch"))
+ (search-patches "php-fix-streams-copy-length.patch"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -178,7 +178,7 @@
,@(if (target-arm32?)
;; Drop tests known to fail on armhf.
'((for-each delete-file
- (list
+ (list
"ext/calendar/tests/unixtojd_error1.phpt"
"ext/opcache/tests/preload_006.phpt"
"ext/opcache/tests/preload_011.phpt"
@@ -200,7 +200,7 @@
'())
,@(if (target-x86-32?)
- ;; Drop tests known to fail on i686.
+ ;; Drop tests known to fail on i686.
'((for-each delete-file
(list
"ext/dba/tests/dba_gdbm.phpt")))
@@ -220,6 +220,12 @@
"sapi/phpdbg/tests/watch_006.phpt")))
'())
+ ,@(if (target-riscv64?)
+ ;; Drop tests known to fail on riscv64.
+ '((for-each delete-file
+ (list "sapi/cli/tests/upload_2G.phpt")))
+ '())
+
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
@@ -419,7 +425,7 @@
("procps" ,procps))) ; for tests
(synopsis "PHP programming language")
(description
- "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
+ "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
language designed primarily for web development but is also used as
a general-purpose programming language. PHP code may be embedded into
HTML code, or it can be used in combination with various web template