summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-01-10 21:27:34 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-19 08:16:47 +0100
commit877df1765ad8440c81293f4943d1f4f44485ba0f (patch)
tree8dfb323c47ef46b4fd5baa0e626c7dffde07607f
parent28cefd2e560d5db60de7e03978ef03f57dd2011f (diff)
gnu: guile-filesystem: Update to 0.2.0.
* gnu/packages/guile-xyz.scm (guile-filesystem): Update to 0.2.0. [source]<url>: Use “https://gitlab.com/lilyp/guile-filesystem”. [home-page]: Likewise. (guile2.0-filesystem): Deleted variable.
-rw-r--r--gnu/packages/guile-xyz.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b998179ee0..67b47581e5 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -898,33 +898,27 @@ is not available for Guile 2.0.")
(define-public guile-filesystem
(package
(name "guile-filesystem")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.com/leoprikler/guile-filesystem.git")
+ (url "https://gitlab.com/lilyp/guile-filesystem")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1shmkc0y9r2sj3kw7hrsnamnp7y8xifkhf3m3rnfxczqg63k67vy"))))
+ "0waiaxcha584d0dc15nvs6gxh4clrfm2bwjidjsbqajgb03l4ngm"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake pkg-config texinfo))
(inputs
(list guile-3.0))
- (home-page "https://gitlab.com/leoprikler/guile-filesystem")
+ (home-page "https://gitlab.com/lilyp/guile-filesystem")
(synopsis "Complementary library to Guile's built-in file system procedures")
(description "@code{guile-filesystem} provides a set of utility functions,
that augment Guile's support for handling files and their names.")
(license license:lgpl3+)))
-(define-public guile2.0-filesystem
- (package
- (inherit guile-filesystem)
- (name "guile2.0-filesystem")
- (inputs (list guile-2.0))))
-
(define-public guile2.2-filesystem
(package
(inherit guile-filesystem)