summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-18 12:41:23 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-18 14:47:19 -0500
commitf1234c7569088531862c84d19ca6350a44ea5aa5 (patch)
treede195319dfa205aa3c107a124757750edda599a1
parent1b78b94f06c56af83874455861205c11cd4fdcfd (diff)
gnu: python-pygit2: Update to 1.11.1.
* gnu/packages/python-xyz.scm (python-pygit2): Update to 1.11.1. [build-system]: Use pyproject-build-system. [arguments]: Delete field. [propagated-inputs]: Remove python-cached-property.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f97faefc65..12a0c9f983 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6500,24 +6500,16 @@ readable format.")
(define-public python-pygit2
(package
(name "python-pygit2")
- (version "1.9.2")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pygit2" version))
(sha256
- (base32 "068bwhirigbh2435abyv4shdxgxvyfqf4dxfmhd4hihivwrl9290"))))
- (build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v")))))))
- (propagated-inputs
- (list python-cached-property python-cffi libgit2))
- (native-inputs
- (list python-pytest))
+ (base32 "1v34xdvh6i5cn5srwicvp0i2kvv8fzsv0v9p72ng081nsczmhgvr"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi libgit2))
+ (native-inputs (list python-pytest))
(home-page "https://github.com/libgit2/pygit2")
(synopsis "Python bindings for libgit2")
(description "Pygit2 is a set of Python bindings to the libgit2 shared library.")