summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-23 14:29:21 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 18:58:47 +0200
commit451b2db3dfc312e750e8c6e38cf5e25ac7579f1f (patch)
tree6dc575755be941f23eecb7b033d2d75fe780bcb9
parentc8799fafa484214f42ff9779a3ed57da7f62481d (diff)
gnu: parted: Support building for the Hurd.
* gnu/packages/disk.scm (parted)[inputs]: Remove lvm2, add hurd-minimal when building for the Hurd. [arguments]: Add configure-flag '--disable-device-mapper' when building for the Hurd. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
-rw-r--r--gnu/packages/disk.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 6cdcf7b9d2..6306504503 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -69,6 +69,7 @@
#:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
@@ -254,17 +255,24 @@ tmpfs/ramfs filesystems.")
"18h51i3x5cbqhlj5rm23m9sfw63gaaby5czln5w6qpqj3ifdsf29"))))
(build-system gnu-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-locales-and-python
- (lambda _
- (substitute* "tests/t0251-gpt-unicode.sh"
- (("C.UTF-8") "en_US.utf8")) ;not in Glibc locales
- (substitute* "tests/msdos-overlap"
- (("/usr/bin/python") (which "python"))))))))
+ (list
+ #:configure-flags (if (target-hurd?)
+ #~'("--disable-device-mapper")
+ #~'())
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-locales-and-python
+ (lambda _
+ (substitute* "tests/t0251-gpt-unicode.sh"
+ (("C.UTF-8") "en_US.utf8")) ;not in Glibc locales
+ (substitute* "tests/msdos-overlap"
+ (("/usr/bin/python") (which "python"))))))))
(inputs
- (list lvm2 readline
- `(,util-linux "lib")))
+ `(,@(if (target-hurd?)
+ (list hurd-minimal)
+ (list lvm2))
+ ,readline
+ (,util-linux "lib")))
(native-inputs
(list gettext-minimal