summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 10:53:19 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 10:53:19 -0400
commit49b0a5ee5f908d8efa8e792f8635f723fd1d26ed (patch)
tree7407c78a137449b7ecb53fea3e61bfb2a5512d30
parenta33a335c89ce3766e2bd662bffc897bd0da2b9cd (diff)
gnu: Add freetype-with-brotli.
* gnu/packages/fontutils.scm (freetype-with-brotli): New variable.
-rw-r--r--gnu/packages/fontutils.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1b4e0064f4..e5170b5ae3 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -124,6 +125,16 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
(home-page "https://freetype.org/")))
+;; TODO: Make this change directly in freetype in the next large rebuild cycle
+;; and remove this package.
+(define-public freetype-with-brotli
+ (package
+ (inherit freetype)
+ (name "freetype-with-brotli")
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs freetype)
+ (prepend brotli)))))
+
(define-public opentype-sanitizer
(package
(name "opentype-sanitizer")