summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-14 11:51:18 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-14 11:54:02 +0100
commit5f7c714c63dd4313dbc0ba466ac73c7fb68966db (patch)
tree4c7a68b265e2834680e6fbcd6aaaa5b099bc47dd
parenta041bbb4bf98cce72b14c554369fc56eeacc2f5d (diff)
gnu: rumpkernel: Don't error for non x86 systems.
As the lack of handling other systems, say aarch64-linux here seemed to cause problems with guix pull on these systems. This should work around #64609. * gnu/packages/hurd.scm (rumpkernel)[arguments]: Don't error for any system.
-rw-r--r--gnu/packages/hurd.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 0e47a954d7..3785c47750 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -746,7 +746,8 @@ in userland processes thanks to the DDE layer.")
((? target-x86-32?)
"i386")
((? target-x86-64?)
- "amd64")))
+ "amd64")
+ (_ "unknown")))
(toprump (string-append
(getcwd)
"/buildrump.sh/src/sys/rump"))