summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobias.kortkamp@gmail.com>2023-06-17 15:31:56 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-13 17:20:02 +0200
commitae92d98b9375e1d753bd9ab495ed5c7dcd3f1af5 (patch)
tree9c5476375f29a8aa90da2a97a8d9b51c56531217
parentdd4c1992103a65b8fbdc80fe07a9fe9be822769a (diff)
gnu: clang-runtime-15: Fix address sanitizer support
$ guix shell clang-toolchain@15 -- clang -o test -fsanitize=address test.c ld: cannot find /gnu/store/i429h17s15g48ir9vl1bzp3cv39l5pib-clang-runtime-15.0.7/lib/linux/libclang_rt.asan_static-x86_64.a: No such file or directory ld: cannot find /gnu/store/i429h17s15g48ir9vl1bzp3cv39l5pib-clang-runtime-15.0.7/lib/linux/libclang_rt.asan-x86_64.a: No such file or directory clang-15: error: linker command failed with exit code 1 (use -v to see invocation) * gnu/packages/llvm.scm (clang-runtime-15): Fix address sanitizer support by bringing back the static libraries. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/llvm.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index de5ad3718b..daff67f7f2 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -699,12 +699,7 @@ of programming tools as well as libraries with equivalent functionality.")
#~(modify-phases #$phases
(add-after 'unpack 'change-directory
(lambda _
- (chdir "compiler-rt")))
- (add-after 'install 'delete-static-libraries
- ;; Reduce size from 33 MiB to 7.4 MiB.
- (lambda _
- (for-each delete-file
- (find-files #$output "\\.a(\\.syms)?$"))))))))
+ (chdir "compiler-rt")))))))
(native-inputs
(modify-inputs (package-native-inputs template)
(prepend gcc-12))) ;libfuzzer fails to build with GCC 11