summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:02 +0200
commitbce8c88f42b0fb26a11fa134d10baad626441fd0 (patch)
tree3edb76845b4971c33aaace5dd3e0a2266f527bbf
parent1d7e1fbc3850185348a5cc712980158a4ac37841 (diff)
gnu: altermime: Use G-expressions.
* gnu/packages/mail.scm (altermime)[arguments]: Rewrite as G-expressions. Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/mail.scm61
1 files changed, 30 insertions, 31 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 717c132e22..c72e99dc0d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -837,37 +837,36 @@ Extension (MIME).")
"15zxg6spcmd35r6xbidq2fgcg2nzyv1sbbqds08lzll70mqx4pj7"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:tests? #f ; there are none
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'fix-bugs
- (lambda _
- (substitute* "MIME_headers.c"
- (("hinfo->filename, sizeof\\(hinfo->name\\)")
- "hinfo->filename, sizeof(hinfo->filename)")
- (("memset\\(hinfo->defects, 0, _MIMEH_DEFECT_ARRAY_SIZE\\);")
- "memset(hinfo->defects, 0, sizeof(hinfo->defects));"))
- (substitute* "pldstr.c"
- (("if \\(\\(st->start\\)&&\\(st->start != '\\\\0'\\)\\)")
- "if ((st->start)&&(*st->start != '\\0'))"))
- (substitute* "qpe.c"
- (("if \\(lineend != '\\\\0'\\)")
- "if (*lineend != '\\0')"))
- #t))
- (add-after 'unpack 'install-to-prefix
- (lambda _
- (substitute* "Makefile"
- (("/usr/local") "${PREFIX}")
- (("cp altermime.*") "install -D -t ${PREFIX}/bin altermime\n"))
- #t))
- (add-after 'unpack 'disable-Werror
- (lambda _
- (substitute* "Makefile"
- (("-Werror") ""))
- #t)))))
+ (list
+ #:make-flags
+ #~(list "CC=gcc"
+ (string-append "PREFIX=" #$output))
+ #:tests? #f ; there are none
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-bugs
+ (lambda _
+ (substitute* "MIME_headers.c"
+ (("hinfo->filename, sizeof\\(hinfo->name\\)")
+ "hinfo->filename, sizeof(hinfo->filename)")
+ (("memset\\(hinfo->defects, 0, _MIMEH_DEFECT_ARRAY_SIZE\\);")
+ "memset(hinfo->defects, 0, sizeof(hinfo->defects));"))
+ (substitute* "pldstr.c"
+ (("if \\(\\(st->start\\)&&\\(st->start != '\\\\0'\\)\\)")
+ "if ((st->start)&&(*st->start != '\\0'))"))
+ (substitute* "qpe.c"
+ (("if \\(lineend != '\\\\0'\\)")
+ "if (*lineend != '\\0')"))))
+ (add-after 'unpack 'install-to-prefix
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr/local") "${PREFIX}")
+ (("cp altermime.*") "install -D -t ${PREFIX}/bin altermime\n"))))
+ (add-after 'unpack 'disable-Werror
+ (lambda _
+ (substitute* "Makefile"
+ (("-Werror") "")))))))
(home-page "https://pldaniels.com/altermime/")
(synopsis "Modify MIME-encoded messages")
(description