summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-06 14:22:02 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:20:56 +0200
commit23929e8a2deb74d9b7af923b21ff5d503cacdeaf (patch)
tree6af6244bcb40d10e3928fd6b6105edd82593da2e
parent1a67104f4b658faa9f640eb80765fd5ebba94b3c (diff)
gnu: python-dbus-python: Add missing input.
* gnu/packages/python-xyz.scm (python-dbus-python)[native-inputs]: Add python-setuptools. Change-Id: I3b813a5a3edcc878b552aa7885a47c1079d7acda
-rw-r--r--gnu/packages/python-xyz.scm60
1 files changed, 31 insertions, 29 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ba37136520..c82a98c780 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29763,36 +29763,38 @@ for YAML and JSON.")
(define-public python-dbus-python
(package
- (name "python-dbus-python")
- (version "1.3.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "dbus-python" version))
- (sha256
- (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
- (build-system pyproject-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-requirements
- (lambda _
- (substitute* (list "pyproject.toml" "setup.py")
- (("'(ninja|patchelf)',?") ""))
- (substitute* "setup.cfg"
- (("(ninja|patchelf)") "")))))))
- (inputs (list dbus glib))
- (propagated-inputs (list python-pygobject))
- (native-inputs (list pkg-config
- python-meson-python
- meson ninja patchelf
- python-sphinx python-sphinx-rtd-theme
- python-tappy
- python-wheel))
- (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
- (synopsis "Python bindings for libdbus")
- (description "This package provides Python bindings to libdbus, the
+ (name "python-dbus-python")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dbus-python" version))
+ (sha256
+ (base32 "1y28h90v2ib8zqhs3r2yr7ycg8ccwvw3gqkvadlm12v1129q2rxd"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* (list "pyproject.toml" "setup.py")
+ (("'(ninja|patchelf)',?") ""))
+ (substitute* "setup.cfg"
+ (("(ninja|patchelf)") "")))))))
+ (inputs (list dbus glib))
+ (propagated-inputs (list python-pygobject))
+ (native-inputs (list pkg-config
+ python-meson-python
+ meson ninja patchelf
+ python-setuptools
+ python-sphinx
+ python-sphinx-rtd-theme
+ python-tappy
+ python-wheel))
+ (home-page "https://dbus.freedesktop.org/doc/dbus-python/")
+ (synopsis "Python bindings for libdbus")
+ (description "This package provides Python bindings to libdbus, the
reference implementation of the D-Bus protocol.")
- (license license:expat)))
+ (license license:expat)))
(define-public python-dbusmock
(package