summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:46:50 +0200
commit04a01e53a2d12dfddea7f80226f3cb272b840081 (patch)
treed7d5ec26dce3bef4c8fd389d519068ff4cae62c7
parent1501275880043faaeb1298b9fe2aa0f49809d90d (diff)
gnu: python-tinycss: Move to pyproject-build-system.
* gnu/packages/python-web.scm (python-tinycss): [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Ignore failing test. Change-Id: I972a3c6390df5f8af79c952292db8a4e24a4aa33 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 265396a644..9aac1a2abe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5871,20 +5871,10 @@ library to create slugs from unicode strings while keeping it DRY.")
(uri (pypi-uri "tinycss" version))
(sha256
(base32 "0vkifr595h28ymkjhrswwf0bm23lhznh5f44xyp7x7jy1ssnyc0j"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-flake8-isort
- ;; Flake8 and isort tests fail.
- (lambda _
- (substitute* "setup.cfg" ((" --flake8 --isort") ""))
- #t))
- (replace 'check
- (lambda _
- ;; Disable failing test.
- (invoke "python" "-m" "pytest" "-k"
- "not test_speedups"))))))
+ (list #:test-flags
+ '(list "-k" "not test_speedups")))
(native-inputs
(list python-pytest-cov python-pytest-flake8 python-pytest-isort
python-pytest-runner))