summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-09 23:03:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-09 23:06:17 +0200
commit0b8beb183020bc3e3226bcbd883c388434c35c0e (patch)
tree5bd61a630314b41b5309282fa14c5562a591957e
parent05bea31e41166494fdc59c6c79bae7f69a5c330f (diff)
gnu: python-pycurl: Update to 7.45.3.
* gnu/packages/python-web.scm (python-pycurl): Update to 7.45.3. [arguments]: Adjust tests. Change-Id: I05120931c979d292c2f888d29c80c93a82a291a0
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dd1e005b72..4619a04942 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1998,13 +1998,13 @@ Amazon S3 compatible object storage server.")
(define-public python-pycurl
(package
(name "python-pycurl")
- (version "7.45.2")
+ (version "7.45.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycurl" version))
(sha256
- (base32 "1ji46b924caa4saxvjxs9h673yy0kif297nxpnjn84r7w05mjc2p"))))
+ (base32 "0sqxz14p8qvhdb9pvlbrfdldn8s27l6hpv252s77kbbrj2pp294c"))))
(build-system pyproject-build-system)
(arguments
'(#:test-flags
@@ -2015,11 +2015,8 @@ Amazon S3 compatible object storage server.")
;; E assert None is not None
;; E+ where None =
;; <tests.multi_callback_test.MultiCallbackTest
- ;; testMethod=test_easy_pause_unpause>.socket_result
- " and not test_easy_pause_unpause"
+ ;; testMethod=test_multi_socket_action>.timer_result
" and not test_multi_socket_action"
- ;; E pycurl.error: (1, '')
- " and not test_http_version_3"
;; OSError: tests/fake-curl/libcurl/with_gnutls.so: cannot
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_gnutls"
@@ -2029,9 +2026,8 @@ Amazon S3 compatible object storage server.")
;; OSError: tests/fake-curl/libcurl/with_openssl.so: cannot
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_openssl"
- ;; pycurl.error: (56, 'Recv failure: Connection reset by
- ;; peer')
- " and not test_post_with_read_callback"))
+ ;; "A libcurl function was given a bad argument"
+ " and not test_proxy_tlsauth"))
#:phases (modify-phases %standard-phases
(add-before 'build 'configure-tls-backend
(lambda _