summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:44:29 +0200
commit2c20560d6eaaf7eeb9aaa811774d4ef99bd44dea (patch)
tree61deae453ffa9ecab8d4a88cc53fc06967bb121c
parent527650275f0d94e11cedde9f6d0a640e1cb63569 (diff)
gnu: Add xcffibgen.
* gnu/packages/xorg.scm (xcffibgen): New variable. Change-Id: Ibcbacdfdeaa657ec1ded7dcc09c10c7fc2aa6717 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/xorg.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 74059a2691..fbe6375818 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1673,6 +1673,39 @@ mechanism than copying the contents of the source pixmap.")
network-transparent printing system.")
(license license:x11)))
+(define xcffibgen
+ (package
+ (name "xcffibgen")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tych0/xcffib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wz6zlaqsmpw7ahaadpd7m5n5c5b2ya30xwsana4j5ljygdvzqp9"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ (list ghc-hunit ghc-test-framework ghc-test-framework-hunit))
+ (inputs
+ (list libxcb
+ ghc
+ ghc-filemanip
+ ghc-split
+ ghc-language-python
+ ghc-attoparsec
+ ghc-either
+ ghc-optparse-applicative
+ ghc-xcb-types))
+ (home-page "https://github.com/tych0/xcffib")
+ (synopsis "Build tool for python-xcbffib bindings")
+ (description
+ "This is an internal package that provides a build tool to
+generate code for the @code{python-xcbffib} package.")
+ (license license:expat)))
+
(define-public randrproto
(package
(name "randrproto")