summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-10 22:04:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:54 +0100
commit2f1d8fb129511469c553caab5a2f4fd370d09fa5 (patch)
tree62fd740dde866020b22b0ea89def3f8444e780c6
parent08b9e29d4672d2209026f4b7fa592abb958cbd34 (diff)
gnu: python-apsw: Update to 3.40.0.0.
* gnu/packages/databases.scm (python-apsw): Update to 3.40.0.0. [source]: Remove obsolete patch. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-cython. [arguments]: Move build-extensions phase before build phase. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch: Remove file.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/databases.scm36
-rw-r--r--gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch27
3 files changed, 18 insertions, 46 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6e12f9cdb1..295be3c67c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1719,7 +1719,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-fix-tests.patch \
%D%/packages/patches/python-3-hurd-configure.patch \
%D%/packages/patches/python-3-no-static-lib.patch \
- %D%/packages/patches/python-apsw-3.39.2.1-test-fix.patch \
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
%D%/packages/patches/python-cross-compile.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b74762789a..9d1eec5ea0 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -173,6 +173,7 @@
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (guix build-system ruby)
@@ -3590,7 +3591,7 @@ PickleShare.")
(define-public python-apsw
(package
(name "python-apsw")
- (version "3.39.2.1")
+ (version "3.40.0.0")
;; The compressed release has fetching functionality disabled.
(source
(origin
@@ -3600,24 +3601,23 @@ PickleShare.")
version "/apsw-" version ".zip"))
(sha256
(base32
- "06x3qgg71xz8l3kz8gz04wkfp5f6zfrg476a4mm1c5hikqyw6ykj"))
- ;; Cherry-picked from upstream, remove when bumping to 3.39.3.
- (patches
- (search-patches "python-apsw-3.39.2.1-test-fix.patch"))))
- (build-system python-build-system)
- (native-inputs (list unzip))
- (inputs (list sqlite-next)) ;SQLite 3.39 required.
+ "02sgja00azvd08wi2wm105apmhp2644s7aw9b1zdg3dkcwjnsiad"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-cython unzip))
+ (inputs (list sqlite-next)) ;SQLite 3.40 required.
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- (invoke "python" "setup.py" "build" "--enable-all-extensions"
- "--enable=load_extension")))
- (add-after 'build 'build-test-helper
- (lambda _
- (invoke "gcc" "-fPIC" "-shared" "-o" "./testextension.sqlext"
- "-I." "-Isqlite3" "src/testextension.c"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build" "--enable-all-extensions"
+ "--enable=load_extension")))
+ (add-after 'build 'build-test-helper
+ (lambda _
+ (invoke "gcc" "-fPIC" "-shared" "-o" "./testextension.sqlext"
+ "-I." "-Isqlite3" "src/testextension.c"))))))
(home-page "https://github.com/rogerbinns/apsw/")
(synopsis "Another Python SQLite Wrapper")
(description
diff --git a/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch b/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch
deleted file mode 100644
index cc233e3ccd..0000000000
--- a/gnu/packages/patches/python-apsw-3.39.2.1-test-fix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 1111f902075169bd0d96cdd10607ef8499f0fed5 Mon Sep 17 00:00:00 2001
-From: Roger Binns <rogerb@rogerbinns.com>
-Date: Mon, 5 Sep 2022 07:12:25 -0700
-Subject: [PATCH] Deal with mismatched SQLITE_ENABLE_COLUMN_METADATA
-
-Address #363
----
- apsw/tests.py | 2 +-
- 1 files changed, 1 insertions(+), 1 deletion(-)
-
-diff --git a/apsw/tests.py b/apsw/tests.py
-index b4a94d3..256ead0 100644
---- a/apsw/tests.py
-+++ b/apsw/tests.py
-@@ -772,8 +772,8 @@ class APSW(unittest.TestCase):
- c.execute("drop table foo; create table foo (%s)" % (", ".join(["[%s] %s" % (n, t) for n, t in cols]), ))
- c.execute("insert into foo([x a space]) values(1)")
- c.execute("create temp table two(fred banana); insert into two values(7); create temp view three as select fred as [a space] from two")
-- has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options)
-+ has_full=any(o=="ENABLE_COLUMN_METADATA" or o.startswith("ENABLE_COLUMN_METADATA=") for o in apsw.compile_options) if apsw.using_amalgamation else hasattr(c, "description_full")
- for row in c.execute("select * from foo"):
- self.assertEqual(cols, c.getdescription())
- self.assertEqual(has_full, hasattr(c, "description_full"))
-
-base-commit: f628374c5857d940067ef26c9ea4e85a08a94f76
---
-2.37.2