summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 11:54:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-08 11:54:19 +0200
commit3a9419002118439ea894f34ecf3b6fd407e8782f (patch)
tree013f0609f34db0a3c65de885e5d880d08fbb3f24
parentba187721f6c0fd8a43fbbda5d68ab3d82b899460 (diff)
gnu: Add python-pytoolconfig.
* gnu/packages/python-xyz.scm (python-pytoolconfig): New variable. Change-Id: I203d68b0eba0b38020a1be98904be386dfc3b2ed
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ecdc990bad..ccabba7997 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2079,6 +2079,33 @@ task of adding retry behavior to just about anything.")
implementation for the Telegram Bot API.")
(license license:gpl2)))
+(define-public python-pytoolconfig
+ (package
+ (name "python-pytoolconfig")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytoolconfig" version))
+ (sha256
+ (base32 "1bnvg9yiwp2fn0lvzhp1dd2mvrymxvjnasmbdap3i0hhdwdbvrji"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-packaging
+ python-platformdirs
+ python-pydantic
+ python-sphinx
+ python-sphinx-autodoc-typehints
+ python-sphinx-rtd-theme
+ python-tabulate
+ python-tomli))
+ (native-inputs (list python-pdm-backend python-pytest))
+ (home-page "https://pypi.org/project/pytoolconfig/")
+ (synopsis "Python tool configuration")
+ (description "The goal of this project is to manage configuration for
+Python tools, such as rope and add support for a @file{pyproject.toml}
+configuration file.")
+ (license license:lgpl3+)))
+
(define-public python-colorlog
(package
(name "python-colorlog")