summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:41:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:49 +0200
commit3c3175d1b67940bf16649fbe21f868c44162cb1a (patch)
tree8319cfa49c1af9b36c926a57ec308b7fd1c9b114
parent5c852f28dcef401252ea988efb04a5ca5f564205 (diff)
gnu: Add texlive-usebib.
* gnu/packages/tex.scm (texlive-usebib): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e61958be6b..956771b4da 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17902,6 +17902,28 @@ file which has a reasonably conventional structure. The result is meant to be
robust rather than pretty.")
(license (list license:gpl2 license:lppl))))
+(define-public texlive-usebib
+ (package
+ (name "texlive-usebib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/usebib/" "source/latex/usebib/"
+ "tex/latex/usebib/")
+ (base32
+ "1qymf8hnp7ilzm030ypbagmw6nicdfy8lhry20viws1v7dibk9l0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/usebib")
+ (synopsis "Simple bibliography processor")
+ (description
+ "The package is described by its author as @emph{a poor person's
+replacement for the more powerful methods provided by BibLaTeX to access data
+from a @file{.bib} file}. Its principle commands are @code{\\bibinput}, which
+specifies a database to use, and @code{\\usebibdata}, which typesets a single
+field from a specified entry in that database.")
+ (license license:lppl1.3+)))
+
(define-public texlive-velthuis
(package
(name "texlive-velthuis")