summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:45:47 +0200
commit3ef0c237b662c3dd8fff34419b6d4d489564be6c (patch)
treee5e9655570ae85e41709f15e61f1af03fe6f408b
parent6cb8b26789ffc88b8299b5af8fbab174e07b7951 (diff)
gnu: python-arrow: Move to pyproject-build-system.
* gnu/packages/time.scm (python-arrow): Improve package style. [build-system]: Move to pyproject-build-system. [arguments]: Moving check replacement phase from <#:phases> to equivalent <#:test-flags>. Change-Id: I7e3d356610d624855c3898ccdbfb308ce9f6e627 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/time.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 5e20f05fb6..96fe9f561a 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -507,17 +507,13 @@ timestamps.")
(sha256
(base32
"189knrgxb3x21lzvqac6qlpd32308hcmpccxdlvr5wmrl46b6d1r"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests"
- ;; python-dateutil doesn't recognize America/Nuuk.
- ;; Remove when python-dateutil > 2.8.1.
- "-k" "not test_parse_tz_name_zzz")))))))
+ (list
+ #:test-flags '(list "tests"
+ ;; python-dateutil doesn't recognize America/Nuuk.
+ ;; Remove when python-dateutil > 2.8.1.
+ "-k" "not test_parse_tz_name_zzz")))
(native-inputs
(list ;; For testing
python-chai