summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 12:05:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:36 +0200
commit3f2c32505f3540939ecfb4b87a5336c58dd49909 (patch)
treea65b352c523b7cd810859d884601d6cd06ce8573
parent31ebfd254d35fa94cf1ca9f673e92f58b48caa97 (diff)
gnu: Add texlive-custom-bib.
* gnu/packages/tex.scm (texlive-custom-bib): New variable.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d64b5b4934..4bf0705964 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7232,6 +7232,38 @@ for structuring exercises, aggregating points, and displaying a grading table,
as well as several macros for easier math mode usage.")
(license license:expat)))
+(define-public texlive-custom-bib
+ (package
+ (name "texlive-custom-bib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/custom-bib/"
+ "source/latex/custom-bib/"
+ "tex/latex/custom-bib/")
+ (base32
+ "1hzy0j9k55ygkzvgs3y2jz435267l3g4isqynr64978zhyqybqpd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; The installation process requires ".mbs" files to be
+ ;; available when generating the package. Extend TEXINPUTS to
+ ;; include their location.
+ (add-before 'build 'extend-texinputs
+ (lambda _
+ (setenv "TEXINPUTS"
+ (string-append (getcwd)
+ "/tex/latex/custom-bib/:")))))))
+ (home-page "https://ctan.org/pkg/custom-bib")
+ (synopsis "Customised BibTeX styles")
+ (description
+ "This package generates customized BibTeX bibliography styles from
+a generic file using @code{docstrip} driven by parameters generated by a menu
+application. It includes support for the Harvard style of citations.")
+ (license license:lppl)))
+
(define-public texlive-customdice
(package
(name "texlive-customdice")