summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:46:55 +0200
commit52fcb9c33ee30ada5c6b7ec4fd42240d1101677a (patch)
tree71906ff38f7a32e140d17beee151bbe84f1913e9
parent04a01e53a2d12dfddea7f80226f3cb272b840081 (diff)
gnu: behave: Move to pyproject-build-system.
* gnu/packages/check.scm (behave): [build-system]: Move to pyproject-build-system. [arguments]: Remove uneeded field. Change-Id: I9ea513fb49b71d9187461ef55c2a6ecab2844a1d Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/check.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5708fa91ac..1d0be03d40 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2990,13 +2990,7 @@ backported from Python 2.7 for Python 2.4+.")
(sha256
(base32
"0sv94wagi214h0l91zn8m04f78x5wn83vqxib81hnl1qahvx9hq7"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-c" "/dev/null" "-vv")))))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-mock python-nose python-pathpy python-pyhamcrest
python-pytest))