summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 12:23:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:43 +0200
commit551db4b475a867e57b6e5ff044311d1b046f5873 (patch)
tree3ff68a83d41d72f1b9cda6427d924f681e993e38
parent4bf771bce92f100470492a11b452ac406125e1ec (diff)
gnu: Add texlive-jurabib.
* gnu/packages/tex.scm (texlive-jurabib): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3827212db0..9c7465da2c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10913,6 +10913,37 @@ helps you to handle abbreviations and creates a list of those (pre-defined)
abbreviations that have actually been used in the document.")
(license license:gpl3+)))
+(define-public texlive-jurabib
+ (package
+ (name "texlive-jurabib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bib/jurabib/" "bibtex/bst/jurabib/"
+ "doc/latex/jurabib/" "source/latex/jurabib/"
+ "tex/latex/jurabib/")
+ (base32
+ "1z8n654n0f97qayql0111smpydwmdf6i22bg55i6nh5al2jcsbbb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/jurabib")
+ (synopsis
+ "Extended BibTeX citation support for the humanities and legal texts")
+ (description
+ "This package enables automated citation with BibTeX for legal studies
+and the humanities. In addition, the package provides commands for specifying
+editors in a commentary in a convenient way. Simplified formatting of the
+citation as well as the bibliography entry is also provided. It is possible
+to display the (short) title of a work only if an authors is cited with
+multiple works. Giving a full citation in the text, conforming to the
+bibliography entry, is supported. Several options are provided which might be
+of special interest for those outside legal studies--for instance, displaying
+multiple full citations. In addition, the format of last names and first
+names of authors may be changed easily. Cross references to other footnotes
+are possible. Language dependent handling of bibliography entries is possible
+by the special language field.")
+ (license license:gpl3+)))
+
(define-public texlive-juramisc
(package
(name "texlive-juramisc")