summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:52:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:43:12 +0200
commit6305b46c05868ce7016e37aa083ef41dd625cf4d (patch)
tree5560ed515739785e89bc27605c31a973e84c9cba
parent8de03411063c549df0b2ba25cfc2409eaa57c7d8 (diff)
gnu: python-isort: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-isort): [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Add option to replace former check phase. <#:phases>: Remove phases build, install and check. Change-Id: Idac8f151977f2494eb44d51aa1fcbf3156b5cc87 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 4 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4051764b5e..6ec3cbe2e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24322,19 +24322,13 @@ package attempts to address the shortcomings of @code{isodate}.")
(sha256
(base32
"1vbwc4gpffclf6hw08lvvgqlvsgfjlw7gjsm28jfcrln2pixla7j"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
+ #:test-flags '(list "tests/unit/" "-k" "not test_gitignore"
+ "--ignore=tests/unit/test_deprecated_finders.py")
#:phases
#~(modify-phases %standard-phases
- (replace 'build
- (lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
- (replace 'install
- (lambda _
- (let ((whl (car (find-files "dist" "\\.whl$"))))
- (invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
(add-after 'install 'install-example-plugins
(lambda _
(for-each (lambda (source-directory)
@@ -24348,15 +24342,7 @@ package attempts to address the shortcomings of @code{isodate}.")
(setenv "HOME" (getcwd))
(let ((example-whls (find-files "dist" "^example.*\\.whl$")))
(apply invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--user" "--no-deps" example-whls))))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (let ((bin (string-append #$output "/bin")))
- (setenv "PATH" (string-append (getenv "PATH") ":" bin)))
- (invoke "pytest" "-vv" "tests/unit/"
- "-k" "not test_gitignore" ;requires git
- "--ignore=tests/unit/test_deprecated_finders.py")))))))
+ "install" "--user" "--no-deps" example-whls)))))))
(native-inputs
(list python-black
python-colorama