summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-13 22:34:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-13 22:34:58 -0400
commit692c2ad327f9e85de5f0b850d86674762558cc05 (patch)
tree1cd8407633ad1f819396b903247142538400f5eb
parentb33e1a183f6756514e6b6a3b84054a232dbddad4 (diff)
gnu: python-gevent: Disable failing test on i686-linux.
Fixes <https://issues.guix.gnu.org/42553>. * gnu/packages/python-xyz.scm (python-gevent) [phases]{adjust-tests}: Skip the test__core_stat.py test suite.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index efcd51db95..cd81cee0f9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16220,7 +16220,11 @@ graphviz.")
"test__doctests.py"
"test__all__.py"
"test___config.py"
- "test__execmodules.py")))
+ "test__execmodules.py"
+ ;; This test contains 'test_unlink', which
+ ;; fails on i686 (see:
+ ;; https://github.com/gevent/gevent/issues/1558).
+ "test__core_stat.py")))
(call-with-output-file "skipped_tests.txt"
(lambda (port)
(format port "~a~%"