summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:49:26 +0200
commit7842947116388e6e853088f7e21737030667891c (patch)
treea892c614a81742c63144fbb31947d157a93e561c
parent9fd0e0fd439f912a7793e39832e33f384f8a56c5 (diff)
gnu: Add ghc-xcb-types.
* gnu/packages/xorg.scm (ghc-xcb-types): New variable. Change-Id: I42d1d49251e9c3d56aecf012a52fff34e678bd94 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/xorg.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2bc6946599..6c894fc45b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023, 2024 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023, 2024 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system haskell)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -88,6 +90,9 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-apps)
+ #:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages inkscape)
#:use-module (gnu packages image)
@@ -963,6 +968,26 @@ rendering commands to the X server.")
(license license:x11)
(properties `((superseded . ,xorgproto)))))
+(define-public ghc-xcb-types
+ (package
+ (name "ghc-xcb-types")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "xcb-types" version))
+ (sha256
+ (base32 "0qdfj4d83b1fjmlysqncgi65ldf3qnrsj4lync95mgbaq2kzxj2r"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "xcb-types")))
+ (inputs (list ghc-xml))
+ (home-page "http://community.haskell.org/~aslatter/code/xcb-types")
+ (synopsis "Parse XML files used by the XCB project")
+ (description
+ "This package provides types which mirror the structures used in the XCB code
+generation XML files and parses these XML files into Haskell data structures.")
+ (license license:bsd-3)))
+
(define-public iceauth
(package
(name "iceauth")