summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:48:29 +0200
commit8cea52c2ad064f5c3d7af624201ed257f012f97f (patch)
tree285b0526aca29420c786bc2502b5a220bee65158
parentc270ae24c74e639e1beaa9b0aee0a16c4f16f947 (diff)
gnu: python-docspec-python: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-docspec-python): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove uneeded field. Change-Id: Ib728c442a130eecebe4dff1e364d997bcca76076 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6980534666..162e795511 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -813,16 +813,8 @@ documentation of programming languages.")
(base32 "0n8m52vxmlvkj7p5jmd4rfdks65rrp4q4vzak44y6kbg9l5qa6y4"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:tests? #false ;there are none
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- ;; We don't have black 23.
- (substitute* "pyproject.toml"
- (("23.1.0") "22.3.0")))))))
- (propagated-inputs (list python-black python-docspec python-nr-util))
+ (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-docspec python-nr-util))
(native-inputs (list python-poetry-core))
(home-page "https://github.com/NiklasRosenstein/docspec/")
(synopsis "Produce docspec data from Python source code")