summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:52:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:43:01 +0200
commit8de03411063c549df0b2ba25cfc2409eaa57c7d8 (patch)
tree0494b0ff86ba57312d4e64abd6b80922dd54e0ac
parentb87a31b3c39b40985de6f654a004c198c077f55c (diff)
gnu: python-black: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-black): Improve package style. [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Improve style of use-absolute-file-names phase. Remove phase check. Change-Id: If2da4b3b0fea4928d1aeb270fbaa4167f20a6ee5 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 00aa7bc9a4..4051764b5e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8264,22 +8264,16 @@ and integrated feature-set for programming Python effectively.")
(sha256
(base32
"0yfahlqc7dsdp1js0cbv706apldnfnlbal9b53cww8n0hs40n0im"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'use-absolute-file-names
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let* ((inpts (or native-inputs inputs))
- (python3 (search-input-file inpts "/bin/python3")))
- (substitute* (find-files "tests" "\\.py$")
- (("#!/usr/bin/env python3(\\.[0-9]+)?" _ minor-version)
- (string-append "#!" python3 (if (string? minor-version)
- minor-version
- "")))))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? (invoke "pytest" "-vv")))))))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "tests" "\\.py$")
+ (("#!/usr/bin/env python3")
+ (string-append
+ "#!" (search-input-file inputs "/bin/python3")))))))))
(propagated-inputs
(list python-click
python-attrs