summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:49:20 +0200
commit9fd0e0fd439f912a7793e39832e33f384f8a56c5 (patch)
tree7c06349a07277bca5c0d96bf3c598a0a34c071ba
parentc998c958fb4ffb81b05c1918a5aca3fc87a6fdbf (diff)
gnu: python-nbstripout: Move to pyproject-build-system.
* gnu/packages/jupyter.scm (python-nbstripout): [build-system]: Move to pyproject-build-system. [arguments]: Convert 'check replacement phase from <#:phases> to <#:test-flags>. Use gexp. Change-Id: I4d97b0739c43371c149296b23951cb2c17129840 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/jupyter.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 62b92fbc8c..63af3069ab 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -833,21 +833,19 @@ nbshow present a single notebook in a terminal-friendly way
(sha256
(base32
"1n57nvxsc94gz9w8ymi83bjkfhfwkpmx4y14m6gjrmlqd49m1aw6"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-bad-tests
- (lambda _
- ;; These tests use git and hg, and they are sensitive to the
- ;; exact printed output.
- (for-each delete-file (list "tests/test-git.t"
- "tests/test-hg.t"
- "tests/test-status.t"
- "tests/test-uninstall.t"))))
- (add-before 'check 'set-CRAMSHELL
- (lambda _
- (setenv "CRAMSHELL" (which "bash")))))))
+ (list
+ ;; These tests use git and hg, and they are sensitive to the
+ ;; exact printed output.
+ #:test-flags '(map (lambda (test)
+ (string-append "--ignore=tests/test-" test ".t"))
+ '("git" "hg" "status" "uninstall"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-CRAMSHELL
+ (lambda _
+ (setenv "CRAMSHELL" (which "bash")))))))
(propagated-inputs (list python-nbformat))
(native-inputs
(list python-pytest