summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 11:56:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-08 11:56:32 +0200
commita015e59c46e008d3bda090260946ade026784365 (patch)
tree03768892f881ae19f92875d5587523ac9bd6fbf8
parent7f1275a33d045fdecabc1dd9a623be4623cd4809 (diff)
gnu: python-platformdirs: Update to 4.2.1.
* gnu/packages/python-xyz.scm (python-platformdirs): Update to 4.2.1. [native-inputs]: Add python-covdefaults and python-pytest-cov. Change-Id: I8cd3e6cbe7a43f7a32566d263e571c0ea9920e17
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2cf774eed..2110fe82fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34663,19 +34663,21 @@ compatible with a wide range of versions of the Stripe API.")
(define-public python-platformdirs
(package
(name "python-platformdirs")
- (version "3.10.0")
+ (version "4.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "platformdirs" version))
(sha256
- (base32 "0vbzyw1k6wvg8gv9cg99ds5pri007c6rqx9668d6kk6pnbd9cmml"))))
+ (base32 "1pwv0fvr6xzykv6dyibp7y3ac66j2w2arsnwh8zcagn69s6x2703"))))
(build-system pyproject-build-system)
(native-inputs
(list python-appdirs
+ python-covdefaults
python-hatchling
python-hatch-vcs
python-pytest
+ python-pytest-cov
python-pytest-mock))
(home-page "https://github.com/platformdirs/platformdirs")
(synopsis "Determine the appropriate platform-specific directories")