summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:46:18 +0200
commitb05c5e72fca0c9cafaac512b69fbb61ea529eb0a (patch)
tree6f5894558360954de6fb0cf27e6177d7f323b607
parentb6c7e2572a6431f12bdeef0d152114b472c5958e (diff)
gnu: python-nbval: Move to pyproject-build-system.
* gnu/packages/python-check.scm (python-nbval): [build-system]: Move to pyproject-build-system. [arguments]: Move <#:phases> check phase replacement into proper <#:test-flags>. [propagated-inputs]: Add python-coverage which should have been there. Change-Id: I93aa282399eb52636ee5561b5d8fb7bb5b93f9e0 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-check.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 913fc00ffc..8e2164a82d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1574,34 +1574,36 @@ notebooks.")
(uri (pypi-uri "nbval" version))
(sha256
(base32 "0h3xrnw0mj1srigrx2rfnd73h8s0xjycclmjs0vx7qkfyqpcvvyg"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-test
- (lambda _
- ;; This test fails because of a mismatch in the output of LaTeX
- ;; equation environments. Seems OK to skip.
- (delete-file
- "tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; This only works with Pytest < 5.
- "not nbdime_reporter"
- ;; https://github.com/computationalmodelling/nbval/pull/148.
- " and not test_timeouts"
- ;; It seems the output format has changed; the following
- ;; test fails with "Unexpected output fields from
- ;; running code: {'text/plain'}".
- " and not test_conf_ignore_stderr "))))))))
+ (list
+ #:test-flags
+ '(list
+ ;; This test fails because of a mismatch in the output of LaTeX
+ ;; equation environments. Seems OK to skip.
+ "--ignore=tests/ipynb-test-samples/test-latex-pass-correctouput.ipynb"
+ "-k" (string-append
+ ;; This only works with Pytest < 5.
+ "not nbdime_reporter"
+ ;; https://github.com/computationalmodelling/nbval/pull/148.
+ " and not test_timeouts"
+ ;; It seems the output format has changed; the following
+ ;; test fails with "Unexpected output fields from
+ ;; running code: {'text/plain'}".
+ " and not test_conf_ignore_stderr "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ (lambda _
+ ;; This test fails because of a mismatch in the output of LaTeX
+ ;; equation environments. Seems OK to skip.
+ (delete-file "tests/\
+ipynb-test-samples/test-latex-pass-correctouput.ipynb"))))))
(native-inputs
(list python-pytest python-pytest-cov python-sympy))
(propagated-inputs
(list python-ipykernel python-jupyter-client python-nbformat
- python-six))
+ python-six python-coverage))
(home-page "https://github.com/computationalmodelling/nbval")
(synopsis "Pytest plugin to validate Jupyter notebooks")
(description