summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-09 22:54:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-09 22:54:51 +0200
commitba4c2035dcfca50e97ef4492b4a3b342b160a338 (patch)
tree61ba9d72e9e30ceb87f6a435320769a00cc292c3
parentdfaa8ed2a5bec94debde44ea285761cf06bdaf38 (diff)
gnu: python-sphinx-5: Disable failing tests.
* gnu/packages/sphinx.scm (python-sphinx-5)[arguments]: Disable three tests that fail for silly reasons. Change-Id: I82d9fd4465fbfe052f8aad2264a9b04d34efef89
-rw-r--r--gnu/packages/sphinx.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 651c5d5b58..2441027afe 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -174,7 +174,15 @@ sources.")
"not test_latex_images"
;; XXX: Not clear why this fails with a version comparison
;; failure.
- " and not test_needs_sphinx"))
+ " and not test_needs_sphinx"
+ ;; This is a harmless failure. The expected output looks for a
+ ;; long string that happens to contain a literal space
+ ;; character, but in the actual output the space character is
+ ;; wrapped in <span class="w"> </span>.
+ " and not test_viewcode"
+ ;; These fail with pygments 2.10+. They are harmless.
+ " and not test_additional_targets_should_not_be_translated"
+ " and not test_additional_targets_should_be_translated"))
#:phases
'(modify-phases %standard-phases
(add-before 'check 'pre-check